# Triggers Pending Deployment After SDK Update to 2.1.0

**URL:** <https://forum.canton.network/t/triggers-pending-deployment-after-sdk-update-to-2-1-0/4389>\
**Category:** App Development\
**Tags:** daml, daml-sdk, damlhub\
**Created:** [April 20, 2022, 5:31pm UTC](https://forum.canton.network/t/triggers-pending-deployment-after-sdk-update-to-2-1-0/4389 "2022-04-20T17:31:54Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![rikotacards](https://avatars.discourse-cdn.com/v4/letter/r/f0a364/32.png) [@rikotacards](https://forum.canton.network/u/rikotacards)\
**Post date:** [April 21, 2022, 2:17pm UTC](https://forum.canton.network/t/triggers-pending-deployment-after-sdk-update-to-2-1-0/4389/3 "2022-04-21T14:17:29Z")

</div>

So just to be extra clear, I should be able to use SDK 2.0 and above for my main dar files, and the triggers should remain at 1.18, correct? I saw that I can use the `data-dependencies` field in the daml.yaml files for projects that use different sdk versions.

---

_[View the full topic](https://forum.canton.network/t/triggers-pending-deployment-after-sdk-update-to-2-1-0/4389)._
