# Wallet SDK Compatibility With Splice v0.6 and Daml 3.5

**URL:** <https://forum.canton.network/t/wallet-sdk-compatibility-with-splice-v0-6-and-daml-3-5/8658>\
**Category:** Outreach\
**Tags:** wallet-exchange-announce, wallets-and-exchanges\
**Created:** [May 19, 2026, 3:51pm UTC](https://forum.canton.network/t/wallet-sdk-compatibility-with-splice-v0-6-and-daml-3-5/8658 "2026-05-19T15:51:05Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dave](https://yyz2.discourse-cdn.com/flex034/user_avatar/forum.canton.network/dave/32/7311_2.png) [@Dave](https://forum.canton.network/u/Dave)\
**Post date:** [May 19, 2026, 3:51pm UTC](https://forum.canton.network/t/wallet-sdk-compatibility-with-splice-v0-6-and-daml-3-5/8658/1 "2026-05-19T15:51:05Z")

</div>

A quick reminder regarding the Splice version 0.6.x updates: **Wallet SDK v0.x is incompatible with Splice v0.6 and Daml v3.5.** If you are using the Wallet SDK, you will need to update to **Wallet SDK v1.1 or later** (latest at time of posting is v1.2.1) to keep everything functioning correctly. The Wallet SDK v1.x is backwards compatible with Splice v0.5.X, but not with v0.4.X.

To help with the transition, please check out the step-by-step instructions in the **[Wallet SDK v0 to v1 Upgrade Guide](https://docs.digitalasset.com/integrate/devnet/wallet-sdk-v1-migration-guide/index.html).**

**We previously announced the details of the new SDK version and compatibility in the forum. You can find the full context here:** [https://forum.canton.network/t/upgrade-to-wallet-sdk-v1-new-long-term-api-for-wallet-providers-and-exchanges/8599](https://forum.canton.network/t/upgrade-to-wallet-sdk-v1-new-long-term-api-for-wallet-providers-and-exchanges/8599)
